Virtual CE PC

May 5, 2011 at 9:06 PM

Have you tested AutoLaunch on a Virtual CE PC machine?

Jan 21, 2013 at 12:25 PM

I've been using AutoLaunch on a Virtual CE PC for some months.

Given that ActiveSync is not available on Virtual CEPC, debugging is made much easier when the CoreCon component option is used with AutoLaunch (no need to click ConManClient2.exe followed by CMAccept.exe).

 

May 18, 2015 at 12:04 AM
Edited May 18, 2015 at 12:33 AM
postlink.bat changes required:

set _CORECONPATH=%CommonProgramFiles(x86)%\Microsoft Shared\Embedded Tools\CoreCon\%VisualStudioVersion%\Target\wce%_WINCEOSVER%\%_TGTCPU%
set _UDPCLIENTPATH=%_WINCEROOT%\3rdParty\AutoLaunch_v320_Compact2013

Can't seem to get this to work with CEPC BSP and Windows Virtual PC. What's the trick?

Am running Compact2013_Desktop_UDP_Listener on Host PC and have included Compact2013UDPClient with AutoLaunch.
Not seeing anything.
VPC is using Loopback NIC, not real NIC with static IPs.
Do I need to use a real NIC with static IPs on each side, host and VPC?

"The last two operations to have an image ready for debugging are:
disable KITL (Kernel Indipendent Transport Layer) due to CoreCon inclusion;
include “Application Builder Debugging Support” component from the catalog items (in CoreOS –> Windows Embedded Compact –> Applications and Services Development –> Diagnostics and Debugging Tools) needed to use the Application Builder (we’ll speak about it in the last post);"

What if I want to also use KITL/KDB?

To answer my own question. Dropping KITL allows VPC NIC to be free. OS image without KITL now has IP address that matches:
[HKEY_LOCAL_MACHINE\Comm\PCI\DC21x41\Parms\TcpIp]
"EnableDHCP"=dword:0
"IpAddress"=multi_sz:"192.168.1.44"
"Subnetmask"=multi_sz:"255.255.255.0"

when I do ipconfig @ CMD:

Pocket CMD v 8.00
> ipconfig
Windows IP configuration


Ethernet adapter [PCI\DC21X41]:
Link-local IPv6 Address . . . . . : fe80::4d37:cf65:fe29:edcb%2 (Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.1.44 (Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 0.0.0.0

But even setting VS2013 @ Configuration Properties, Debugging, IP Address: 192.168.1.44
deploy fails.

I can ping VPC from host:

'>ping 192.168.1.44

Pinging 192.168.1.44 with 32 bytes of data:
Reply from 192.168.1.44: bytes=32 time<1ms TTL=128
Reply from 192.168.1.44: bytes=32 time<1ms TTL=128
Reply from 192.168.1.44: bytes=32 time<1ms TTL=128
Reply from 192.168.1.44: bytes=32 time<1ms TTL=128

Ping statistics for 192.168.1.44:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms

Got everything working once I built application with:
Configuration Properties, Linker, Generate Debug Info, Yes (/DEBUG)

This is no longer a discussion.
This is a solution.
Coordinator
May 26, 2015 at 11:15 PM
@DougMoore

Thanks for catching the following problem:
-  set _UDPCLIENTPATH=%_WINCEROOT%\3rdParty\AutoLaunch_v310_Compact2013
Which should be:
-  set _UDPCLIENTPATH=%_WINCEROOT%\3rdParty\AutoLaunch_v320_Compact2013
With both v310 and v320 on my machine, this error did not cause compilation error.

When working with Virtual PC or Hyper-V virtual machine, Legacy Network adapter is needed.